We have a gated community but some pages appear to be public. Plese help!

Hi,

All our pages redirect to the loginscreen (good) except several ones. What do we have to do in order they are gated pages as well? I do not find the place where we can change this setting.

Thanks,

Jan

Parents
  • Hi Jan,

    Have you removed the "Read Site" permission from the Everyone role? this will prevent non-registered users from seeing site pages.

    If that doesn't resolve it, which pages specifically are being accessed? member pages? specific group?

  • Thanks, I tried that and after saving the settings (Membership > Roles > Everyone > Permission > Read site - disabled), and opening a new anonymous browser tab, the pages were still accessible (not the rest of pages though).

    They are all Custom Pages, the Platform defined pages are well gated behind the login form.

    But not the Custom Pages.

    I can provide momentary links if necessary.

    Thanks for any help!

Reply
  • Thanks, I tried that and after saving the settings (Membership > Roles > Everyone > Permission > Read site - disabled), and opening a new anonymous browser tab, the pages were still accessible (not the rest of pages though).

    They are all Custom Pages, the Platform defined pages are well gated behind the login form.

    But not the Custom Pages.

    I can provide momentary links if necessary.

    Thanks for any help!

Children