Has anyone used an Azure Logic App or Azure Function with Telligent webhooks?

I experience inconsistent behavior when configuring a webhook to post to Azure Logic Apps and Azure Functions.

{
"events": [{
    "TypeId""<TypeId>",
    "DateOccurred""<DateOccurred>",
    "EventData": {
        "ActorUserId"<ActorUserId> ,
        "ContentId""<ContentId>",
        "ContentTypeId""<ContentTypeId>",
        "ForumReplyId"9999,
        "ForumThreadId"9999,
        "ForumId"<ForumId>
        }
    }]
}
Azure Logic Apps and Azure Functions both provide endpoints. I added these to Admin > Integrations > Webhooks in the Telligent Admin Console.
When I send this JSON from Postman to both a Logic App and Function, it is intercepted by both as expected.
When a webhook event is triggered, the Logic App successfully intercepts it.
When a webhook event is triggered, the Function app does not intercept it.
I am baffled and was curious if anyone else has encountered this.
This is for a Slack integration by the way
Thank you
Parents
  • This worked first time for me as a Logic App and Function App. 

    Here's the HTTP trigger code (node.js) for the Function App;

    I'm simply logging the payload so that we can check what was sent.. you can see it in the Monitor...

    So I'm not sure why you've got issues.. it's working for my sandbox instance (which is hosted in Azure).

Reply
  • This worked first time for me as a Logic App and Function App. 

    Here's the HTTP trigger code (node.js) for the Function App;

    I'm simply logging the payload so that we can check what was sent.. you can see it in the Monitor...

    So I'm not sure why you've got issues.. it's working for my sandbox instance (which is hosted in Azure).

Children
No Data