Custom Plugins in TC10.X

Hello There,

I am trying to deploy my custom Widget extension and deploy it in the TC site and unable to see the custom API in the list of API. I could see all the out of box Telligent APIs and not the custom API.

I followed the guidelines given in the below URL and still not able to achieve it.

Kindly help us in fixing the issue.

Any help is appreciated!!


  • Are you seeing the plugin listed in /administration at all (such as under Extensions or via the search feature in administration)? If not, are you seeing any exceptions logged during application startup related to the initialization of your plugin? Would it be possible to share some of your code?

  • Hi Micheal,

    The plug ins are not getting listed in the search feature.From the exception table, I could see this error:

    CSException: Unable to obtain the distributed lock 'PluginManager-InstallUninstallPlugins' during an install. Plugins were unable to be installed and has left the application in an incomplete state.
    at Telligent.Evolution.Components.CSException.InitializeEffectiveStackTraceSet()
    at Telligent.Evolution.Components.CSException.Internal(CSExceptionType type, String internalMessage)
    at Telligent.Evolution.Components.PluginManager.EnsureEnabledPluginsLoadedAndInitialized()
    at Telligent.Evolution.Components.PluginManager.Initialize()
    at Telligent.Evolution.Components.PluginManager.EnsureInitialized()
    at Telligent.Evolution.FirstRequestInitialization.Initialize(HttpContext context)
    at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
    at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
    at System.Web.HttpApplication.PipelineStepManager.ResumeSteps(Exception error)
    at System.Web.HttpApplication.BeginProcessRequestNotification(HttpContext context, AsyncCallback cb)
    at System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context)
    at System.Web.Hosting.PipelineRuntime.ProcessRequestNotificationHelper(IntPtr rootedObjectsPointer, IntPtr nativeRequestContext, IntPtr moduleData, Int32 flags)
    at System.Web.Hosting.PipelineRuntime.ProcessRequestNotification(IntPtr rootedObjectsPointer, IntPtr nativeRequestContext, IntPtr moduleData, Int32 flags)

    I don't see this exception every time i tried to deploy the extensions. 

    Please let me know if you need any other information.


  • Hmm, hard to know fully if that's related. What is your full version? Also, possible to share some of your plugin?

  • Hi Michael,

    Apologies for the late reply. Just gave a shot by connecting to the back up of my db and it worked like a charm. My db might be corrupted.

    Thanks for your support. Appreciate it!!